Exchange Server Share

… Information sharing on Exchange Server …

How To: Recreate OWA Virtual Directory – Exchange 2007

So many times I heard that OWA doesn’t work on Exchange 2007 server. There would be many reason behind it, like permission configuration, missing files, not able to load properly, .net errors ect…

There are different solutions base on various reasons but no one works then you may try by recreating OWA virtual directory which is giving problem.

Check and note the settings of directory in EMC before recreating it, like InternalURL, ExternalURL, Forms-Based Authentication settings ect..



  • First step is to identify the directory which is giving the problem.

      You can use Get-OwaVirtualDirectory to get the list of virtual directories.


  • Now let’s say I have problem while accessing owa directory. Remove it with below command.

Remove-OwaVirtualDirectory “owa (Default Web Site)”


  • Now create it again with below command.

New-OwaVirtualDirectory -OwaVersion “Exchange2007″ -Name “owa (Default Web Site)”


Note: if you are recreating other than owa directory which are legacy Exchange directories then you need to use “Exchange2003or2000” in OWAVersion switch instead of “Exchange2007”

  • Now configure the “owa” virtual directory settings like InternalURL, ExternalURL, Forms-Based Authentications etc… & check the OWA by logging with some test users.


Technorati Tags: ,,

LiveJournal Tags: ,, Tags: ,,

Written by Amit Tank

July 16, 2008 at 4:02 pm

Posted in Exchange, Exchange 2007, OWA

4 Responses

Subscribe to comments with RSS.

  1. […] How To: Recreate OWA Virtual Directory – Exchange 2007 […]

  2. Thank you, thank you, thank you!!!
    I worked 7 days, because i had ever and ever Errors..
    Now i reinstalled owa, and all is functional!!

    I am very happy!

    Thank you, thank you, thank you!!!

    Thomas Hrusovar

    November 26, 2008 at 6:08 pm

  3. I have been pulling my hair out with errors. I tried the above mentioned in PS (Exchange 2007) and the wierdest thing, I get an error when I try any owa cmdlt.
    The error: “The term ‘Remove-OwaVirtualDirectory’ is not recognized as a cmdlet, function, operable program, or script file.”

    Any help or feedback would be appreciated. BTW thanks for sharing all your knowledge, the site is great.

    Mike Slomanski

    January 9, 2009 at 7:22 pm

  4. One note to add, when creating the new directories that are Exchange 2003 or 2000 compatible, you have to set ‘ -VirtualDirectoryType’ according to what the folder will do.

    Tyler Ward

    January 12, 2009 at 10:38 pm

Comments are closed.


Get every new post delivered to your Inbox.

Join 35 other followers

%d bloggers like this: